
Document Preparation 
Guide

Notes: 
• This document is excerpted from the Kurzweil 3000 for Windows 

User’s Guide Version 10, where it appears as Chapter 19.

• Cross-references that appear in blue are active links. All other 
cross-references are inoperative, and refer to locations in other 
chapters of the Kurzweil 3000 for Windows User’s Guide 
Version 10.

• About Document Preparation on page 2.

• Editing Image Documents on page 4.

• Enabling Editing in Image Documents on page 5.

• Zone Editing Image Documents on page 6.

• Re-Recognizing Pages on page 16.

• Correcting Recognition (OCR) Errors on page 17.

• Editing Underlying Text on page 22.

• Working with Pronunciations Dictionaries on page 25

• Working with the Header/Footer Editor on page 32.

• Specifying a New First Page Number on page 38.

• Specifying Front Matter Page Numbers on page 39

• Cleaning Up Image Documents on page 40.

• Using Ranked Spelling to Correct Spelling Errors on page 43.

• Changing the Language Format of Image Text on page 46.
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About Document Preparation
About Document Preparation
After you have brought a document into Kurzweil 3000 by scanning it, by 
opening it using the KESI Virtual Printer or by opening an existing image file, 
you will often need or want to perform some document preparation tasks. 
Document preparation consists of editing a document for optimum reading by 
Kurzweil 3000.

Document preparation includes one or more of the following tasks:

• Re-recognizing pages.

• Editing zones.

• Editing headers and footers.

• Specifying a new first page number or front matter.

• Correcting recognition errors.

• Editing underlying text.

• Correcting pronunciation.

• Cleaning up images.

• Correcting spelling errors.

Preparing Tests and Worksheets
Frequently, the document you are preparing is a test or worksheet. With 
these types of documents, you will often want to add Notes and other types 
of guidance to help students complete the assigned task(s). For details on 
additional preparatory steps for test and worksheets. See Chapter 20, Test 
Preparation and Administration.
Note: If you plan to use annotations such as Sticky Notes, Text Notes, and 
Footnotes, in any document, you should always re-recognize pages and 
zone edit documents first, as annotations are discarded by the zone editing 
process.
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Using the Document Preparation Toolbar
If you are planning on doing a lot of document preparation, it can be helpful 
to use the Document Preparation toolbar. This toolbar contains the most 
commonly used tools for scanning and for preparing documents for proper 
reading.

To display the Document Preparation toolbar set:
From the Tools menu, choose Customize, then Apply Toolbar Set, and 
select Document Preparation from the submenu.

This customized toolbar set provides the tools necessary to prepare new 
image documents: 

• Zone Edit to designate when special text areas (for example, sidebars) 
are read. 

• Spell Check.

• Edit (Underlying) Text to correct OCR errors.

• Header/Footer Editor to mark headers and footers so that Kurzweil 
3000 doesn’t read them.

• Fill in the Blanks to automatically add Text Notes to answer lines in tests 
or worksheets.

• Note Options to specify Sticky Note and Text Note characteristics, such 
as initial size, text color, background color, etc.

• Options for quick access to the Options dialog box.

• Reading Toolbar to display only page navigation and viewing options.
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Editing Image Documents
Editing Image Documents
If you are preparing material for students, once you’ve brought it into 
Kurzweil 3000, you should have Kurzweil 3000 read the document aloud to 
determine the following:

• If there are errors produced during the recognition process. 

This could include misspellings and disconnected words. Correcting 
recognition errors is especially important when preparing the material for 
reading and studying by poor readers and spellers, and for testing 
purposes. 

If there are errors, one of the first things to try is to select a different OCR 
engine, and use the Re-Recognize Page command and see if the new 
OCR engine produces fewer errors. The Re-Recognize Page command 
essentially allows you to “rescan” the page without having to use a 
scanner. See Re-Recognizing Pages on page 16.

Kurzweil 3000 automatically checks and replaces common recognition 
errors based on an internal Corrections list. You can view and edit this list 
as well as correct errors individually by using the following methods: 

Edit the underlying text using the Edit Underlying Text feature. See 
Editing Underlying Text on page 22.

Add new global automatic corrections to the Corrections list. See 
Correcting Recognition (OCR) Errors on page 17.

• If there are pronunciation errors.

The way Kurzweil 3000 pronounces words is determined by a 
Pronunciations Dictionary. Each speaking voice has its own 
Pronunciation Dictionary. You can change the pronunciation of a word 
using the Pronunciation Editor. See Using the Pronunciation Editor on 
page 26.

• If the reading order is how you want the material presented to the 
students. 
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For example, are there parts of the document, sidebars and captions that 
you want read after the students have read the main text? Is there an 
advertisement or some other text that is not relevant and therefore should 
not be read aloud? 

To change the reading order of an image document, Kurzweil 3000 
provides you with a Zone Editor. See Zone Editing Image Documents on 
page 6.

Enabling Editing in Image Documents
By default, Kurzweil 3000 is set to enable editing. If you find, however, that 
you are unable to make changes in image documents, open the Edit menu 
and make sure that Enable Editing is selected. 

When editing is enabled you can:

• Move existing pages. 

• Replace or change underlying words. 

• Edit underlying text.

• Scan, rescan, delete, insert or renumber pages.

• Drag and drop text between image and text documents.

• Zone edit documents.

• Use highlighting, annotations, Voice Notes and Bookmarks.

• Save or discard a page view.
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Zone Editing Image Documents
Zone editing allows you to specify how Kurzweil 3000 handles blocks of text, 
or zones, in an image document. 

If you are a teacher, you can use zone editing to change the order in which 
portions of text are read or to eliminate some portions. For example, it may 
be helpful to your students if you designate photo captions, graphs, sidebars 
and page numbers as Secondary Text, which Kurzweil 3000 reads only when 
a reader clicks on it.

Using the Zone Editor, you can:

• Change the properties and reading order of zones.

• Adjust the size of a zone to determine how much text it encloses.

• Add new zones.

• Delete specific zones (removes the zone definition and the underlying 
text, but not the image you see on the screen).

• Delete All Zones.

To perform zone editing functions, first switch to zone edit view, then use the 
Zone Editor from the right mouse button menu to perform the tasks you 
want. 

When to Zone Edit?
It is highly recommended that you zone edit your documents as the first step 
in document preparation. This provides the most efficient workflow. However, 
you can perform most document preparation tasks, such as editing 
underlying text, moving pages and changing word pronunciations, before 
you zone edit. 

You should not add Bookmarks, Footnotes, Color Highlighting or Text 
Circles, Bubble Notes, or Voice Notes to a document you plan on zone 
editing, as you cannot open the Zone Editor if any of these annotations are 
present. You may, however, add Sticky Notes or Text Notes before zone 
editing.
6



Document Preparation Guide
Note: When you zone edit a document whose underlying text has been 
previously edited, the Zone Editor prompts you to confirm each underlying 
text change it encounters before it applies any zone edits.

To switch to zone edit view and access the Zone Edit menu:
1. From the Scan menu, choose Zone Editor.

The document appears in zone edit view, and Zone Editor Active 
appears in the title bar of the Kurzweil 3000 window.

2. Click on a zone to select it.

3. Press the right mouse button to see the Zone Editor shortcut menu.

Zones appear in numbered, 
outlined blocks of text.
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Note: The Zone Editor shortcut menu’s Help command displays a list of 
all the Zone Editor shortcut keys, which can help you zone edit your 
documents more easily.

4. To exit zone edit view, open the Scan menu and click Zone Editor again 
to clear the check box, or press the right mouse button and deselect 
Zone Editor.

5. If you made any changes, a confirmation message appears. Click Yes.

Note: When you zone edit a document whose underlying text has been 
previously edited, the Zone Editor prompts you to confirm each 
underlying text change it encounters before it applies the zones.

Navigation, Views and Custom Pagination in Zone Editor
While in the Zone Editor, you can:

• Move from page to page in a multi-page image document.

• View the page at different sizes.

• Set the first page number.

To move from page to page in Zone Edit mode:
There are three ways you can do this. Be sure you are in Zone Edit mode.

• Use the Page Up/Page Down keys.

• Click the Page Number box and buttons in the toolbar.

• Use the View->Page submenu.
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To change views in Zone Edit mode:
There are a few view options when you are zone editing: 

• Zoom on the Zone Editor right mouse button menu.

• Zoom from the View menu.

• Zoom buttons on the toolbar.

• You can use the Fit To feature, which is also accessible from the View 
menu.

Note: If you made any changes on a page and go to another page, a 
confirmation message appears to ensure that you intended the changes.

Adding Zones
You can add a new zone to a document. You may want to do this, for 
example, if you have adjusted an existing zone to a smaller size and want to 
create a new zone for the remaining text. By default, new zones are primary 
text, and they take the next available reading order.

To add a zone:
1. Open the Tools menu, and choose Zone Editor.

The document appears in zone edit view.

2. With no zone selected, press the right mouse button to see the Zone 
Editor shortcut menu.

3. Choose Add Zone.

The cursor changes to a crosshair.

4. Hold down the left mouse button and drag to define the zone. As you 
drag, a red rectangle shows the area you’ve defined.

5. Adjust the new zone, if needed.

When you add a zone and release the mouse button, the rectangle 
remains on screen. This means that you are in adjustment mode, so you 
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Zone Editing Image Documents
can easily resize or move the new zone. After adjusting the rectangle, 
click elsewhere in the image to leave adjustment mode.

Setting Zone Properties
Each zone has two properties: Zone Type and Reading Order.
• Zone Type determines how Kurzweil 3000 treats the text during reading.

Primary Text is text that Kurzweil 3000 reads in the order you have 
specified.

Secondary Text is text that Kurzweil 3000 reads only when you choose 
to hear it. To hear Secondary Text, you must click at the beginning of the 
text block, then click the Read button or press F3. Secondary text is 
useful for areas like sidebars.

Graphic specifies a zone that you never want read aloud. This may be 
an actual graphic or some other part of a page you don’t want Kurzweil 
3000 to read.

Note: If you don’t want Kurzweil 3000 to read parts of a page that repeat 
from page to page, such as headers and footers, you should use the 
Header/Footer Editor, which lets you mark these areas more quickly. 
See Working with the Header/Footer Editor on page 32.

Override OCR lets you fix text that Kurzweil 3000 did not recognize 
during the OCR process. For detailed information see Using the Override 
OCR Zone Property on page 11.

• Reading Order is the order in which Kurzweil 3000 reads the Primary 
Zones. If you change the reading order for a given zone, Kurzweil 3000 
automatically renumbers the zones.

Note: By default, when you create a zone, Kurzweil 3000 sets its Zone Type 
to whatever is currently selected in the Zone Properties dialog box. The 
default Zone Type is Primary Text. If you select, for example, Graphic, 
Kurzweil 3000 will then create Graphic zones until you select a different Zone 
Type.
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To specify zone properties:
1. Open the Tools menu, and choose Zone Editor.

The document appears in zone edit view.

2. Double-click the zone for which you want to set properties.

The Zone Properties dialog box appears.

The dialog box displays the current zone’s Zone Type and Reading 
Order.

3. Set the properties for the current zone.

4. Click OK to accept your changes, or click Cancel to forget them.

Using the Override OCR Zone Property
There might be times when the OCR process is unable to recognize certain 
text. This may occur, for example, in a heading that uses a large or unusual 
font or text with wide word spacing. It may also happen when a document is 
composed of many colors or particularly dark backgrounds.

The Override OCR feature, available in Kurzweil 3000 Professional, enables 
you to convert unrecognized text into zones that Kurzweil 3000 can read. 
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To override OCR:
1. Once you’ve determined that there is text that the OCR process did not 

successfully recognize, choose Zone Editor from the Scan menu, or 
press CTRL+F5.

The example below shows a document in Zone Edit mode. Notice that 
the OCR recognized the “By” line and shows it as a zone, but it did not 
recognize the title.

Note: There also may be extra non-essential zones on the page. If this is 
the case, you should first Delete those zones.

2. Choose Add Zone from the Zone Editor right mouse button menu.

The cursor changes to a crosshair.

3. Select the word you want by dragging the cursor over it.

Note: It’s possible to select a group of words; however, Kurzweil 3000 will 
highlight the group, not each word as it reads.

Recognized zone has a 
frame around it and 
highlighted text.

Non-recognized zone.
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4. Click once outside the new zone. The new zone remains selected.

5. Click back inside the zone.

The Zone Properties dialog box appears.

6. Select Override OCR, then type the word in the text box.

So, for example, if Kurzweil 3000 did not recognize the word 
“Underground” type “Underground” in the text box.

7. Click OK.

8. Click outside the zone to deselect it.

9. Repeat steps 2 through 8 until all the desired words are converted to 
readable zones.

10. Exit Zone Edit by clicking Zone Editor from the Zone Editor right mouse 
button menu, or by pressing CTRL+F5

11. Click Yes to confirm and apply the zone editor changes.

Adjusting Zones
You can adjust the size of any zone to change the amount of text it 
encompasses.

To adjust a zone:
1. From the Tools menu, choose Zone Editor.
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The document appears in zone edit view.

2. Click on a zone to select it.

3. Press the right mouse button to see the Zone Editor menu.

4. Choose Adjust Zone.

5. Move or resize the zone border.

To resize the zone, move the cursor until it is near the zone border, then 
hold down the left mouse button and drag the border to its new size. 

To move the zone, move the cursor toward the middle of the zone, then 
hold down the left mouse button and drag it to the new location.

6. When you’ve adjusted the zone release the left mouse button. Click 
elsewhere in the image to leave adjustment mode.

Removing Zones
You have the option of deleting a single zone, or all zones. When you delete 
a zone, the image remains in the displayed document.

To remove a zone:
1. From the Tools menu, choose Zone Editor.

The document appears in zone edit view.

2. Select the zone you want to cut by clicking on it.

The zone changes color to show that it is selected.

3. Press the right mouse button to see the Zone Editor shortcut menu.

4. Choose Delete Zone.

The zone box disappears.

To remove all zones:
1. From the Tools menu, choose Zone Editor.

The document appears in zone edit view.
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2. Click anywhere in the document.

3. Press the right mouse button to see the Zone Editor menu.

4. Choose Delete All Zones.

All of the zones disappear.

If you remove all zones and then exit from the Zone Editor, all of the deleted 
zones are regenerated. You must leave one “dummy” zone (a Graphic zone 
would be a good choice) in order to ensure that the other deleted zones stay 
deleted.
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Re-Recognizing Pages
Use the Re-Recognize Page command to reapply the character recognition 
phase of the scanning process to an image document, without the need of a 
scanner. This is most helpful if you have a document that exhibits a large 
number of pronunciation errors, and you want to try a different OCR engine, 
with the goal of decreasing the errors.
Note: It is always best to re-recognize pages, if necessary, as the first step 
in document preparation, for the following reasons:

• The process removes any zone editing that you may have done. Also, if 
the document contains any Notes or color highlights you must remove 
them before you can re-recognize the page. 

• Although the re-recognition process does not discard underlying text 
editing, Kurzweil 3000 prompts you to confirm each instance of editing 
that it encounters. If you have a large number of edits, this process can 
be lengthy.

To re-recognize a page:
1. If desired, select a different OCR engine. See Selecting an OCR Engine 

and Language on page 276.

If you are going to re-recognize a document using a different OCR 
engine, you must close the document, then select the desired OCR 
engine, and then re-open the document.

2. From the Scan menu, select Re-Recognize Page.

Kurzweil 3000 re-recognizes the page using the newly selected OCR engine.
Note: The re-recognize option does not allow you to change scanning 
options such as Brightness or any of the options listed in the Extras area of 
the Scanning Options pane. See Setting Scanning Options on page 268.
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Correcting Recognition (OCR) Errors
The Optical Character Recognition (OCR) process, which takes place 
whenever you either scan a document or open an image-based document, 
such as a PDF or TIFF file, is both convenient and effective, but it can’t 
provide completely error-proof text recognition. Therefore, Kurzweil 3000 
provides the following methods for correcting recognition errors:

• You can correct errors in individual documents using either the Edit 
Underlying Text Editor or the Change Underlying Word feature. When 
you make changes using either of these methods, your changes are not 
applied to any other documents. See Editing Underlying Text on page 22.

• You can add corrections to the Corrections list. If you find that you are 
frequently correcting one or more words in your documents, you can add 
a correction for this word to the global Corrections list. Kurzweil 3000 
uses this list when it recognizes a new document, and automatically 
applies corrections. See the following section.

Working with the Corrections List
Since correcting recognized text requires you to edit the underlying text, 
which can be time-consuming, Kurzweil 3000 provides a default set of 
corrections for common OCR errors. The software finds and automatically 
corrects the errors to significantly reduce your editing time. 

In some instances, the Corrections list might not contain a correction for a 
particular word. In such cases, you can view and edit this set, as well as add 
corrections of your own. 
Note: Any changes you make to the Corrections list will not apply to the 
current document or any existing image documents. In order for new 
corrections to be applied to existing image documents, you must either 
rescan them or open each one and apply the Re-Recognize command from 
the Scan menu. See Re-Recognizing Pages on page 16.
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To add a new OCR correction using Find and Replace:
1. From the Edit menu, choose Find, then Replace Text.
2. In the Replace dialog box, click in the Find box, and type the OCR error 

you want to replace. In the Replace with box, type the correction. 

If you want the search and replace to be case sensitive, check the Case 
Sensitive box.

3. Click Replace Permanently. 

You can now see the new correction in the OCR Corrections dialog box, 
by selecting Corrections from the Scan menu.

To view and/or edit the default OCR error set:
1. From the Scan menu, choose Corrections.

The Corrections dialog box appears. The Find Word box contains the 
default text errors that Kurzweil 3000 automatically checks for and 
corrects.

2. Select the desired error. (Scroll to see errors not in view.)

3. Type the desired new correction in the Replace With box, then click OK.
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To add a new word to the Automatic Corrections list:
1. From the Scan menu, choose Corrections.

The Corrections dialog box appears. 

2. Click Add New.

The Add Correction dialog box appears.

3. In the Replace text box, type the new word.

4. In the With text box, type the word that you want the word in the Replace 
text box to be replaced with during recognition.

5. Enable Case Sensitive if you only want the replacement to occur when 
the case of the word in the document matches the case of the word in the 
Replace text box.

6. Click OK to add the new correction to the list.

Deleting and Restoring the Corrections List
If over time you have added many corrections to the Corrections list, you 
might, for some reason, want to restore the default Corrections list. 

To restore a Corrections list:
1. From the Scan menu, choose Corrections.

2. In the Corrections dialog box, click Advanced.
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The Advanced options appear.

3. Optionally, save the current list for future use by exporting it.

Any corrections that you added to the original list are lost when you 
restore the default Corrections list.

4. Click Delete All.
Kurzweil 3000 deletes the Corrections list.

5. Click Defaults.

Kurzweil 3000 reloads the default Corrections list.

Importing and Exporting Corrections Lists
The Import and Export Corrections options allow you to distribute 
Corrections lists among Kurzweil 3000 users. This comes in handy in 
situations where there are typically one or two people who perform document 
preparation tasks, and where, as one of their tasks, they are responsible for 
adding corrections to a master list. They can periodically export the master 
list so other Kurzweil 3000 users can import it. This ensures that when newly 
prepared documents are distributed, each Kurzweil 3000 user will have the 
most up-to-date Corrections list.

To export a Corrections list:
1. From the Scan menu, choose Corrections.

2. In the Corrections dialog box, click Advanced.
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The Advanced options appear.

3. Click Export.
4. In the Save As dialog box, navigate to the location where you want to 

save the list.

5. Type a file name for the list, and click Save.

Kurzweil 3000 saves the list as a text file.

To import a Corrections list:
1. From the Scan menu, choose Corrections.

2. In the Corrections dialog box, click Advanced.

The Advanced options appear.

3. Click Import.
4. In the Open dialog box, navigate to the location where the list you want 

is located.

5. Click Open.

6. Click OK. 

Kurzweil 3000 imports the new Corrections list, adding the words to the 
currently loaded list and replacing any words that match. If you click 
Cancel, nothing changes.

Note: You can edit corrections lists with a text editor, such as Notepad.
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Editing Underlying Text 
Scanned documents, files such as PDF and TIFF files and documents you 
open using the KESI Virtual Printer, are all image documents. The OCR 
software recognizes text in these documents and saves it as underlying text. 
In some instances, text can be misrecognized, causing Kurzweil 3000 to read 
words improperly. When this happens, you can edit the underlying text to 
correct the mistake.

To edit the underlying text of an image document:
1. Open an image document that you want to edit.

2. From the Edit menu, choose Correct Recognition, then Edit 
Underlying Text.
Kurzweil 3000 enters Edit Underlying Text mode and the underlying text 
editing window opens below the current document.

The scrollable editing window displays one page of an image document’s 
underlying text at a time. When you click on a word in the editing window, 
Kurzweil 3000 highlights the word in both the window and in the 
document. Likewise, if you click on a word in the document, it becomes 

Image Document

Underlying Text 
Editing Window

Selected Word Box

Selected Word
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highlighted in both places. Also, the word you click appears in the 
Selected Word box at the bottom of the editing window.

To move to a different page, use the Page navigation control in the 
Reading toolbar, or the commands in the View menu’s Page submenu.

You can also move through the document using shortcut keys. See 
Accessing Functions and Features from the Keyboard on page 363 of the 
Kurzweil 3000 for Windows User’s Guide.

3. Click on a word that you want to edit. 

Click the Read button to hear the word read and confirm that this is the 
word you want to correct.

4. Click in the Selected Word box, and edit the word to correct the 
misrecognition.

5. Click Read to confirm your correction.

6. Click OK to leave Edit Underlying Text mode and apply your 
corrections.

To change a single underlying word in an image document:
1. Double-click on the word you want to change.

2. From the Edit menu, choose Correct Recognition, then Change 
Underlying Word.

3. In the With text box of the Change Underlying Word dialog box, type 
the replacement.

 

4. Click OK. 
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Note: If you click on a word that is within an OCR Override zone, the zone's 
override text appears in the Change Underlying Word dialog box. See 
Using the Override OCR Zone Property on page 11.

Using Editing Functions to Correct Underlying Text Errors
If you have a multi-page image document, you can also use the following 
editing functions to automatically correct recognition errors in it:

• Find and Replace words. Access these functions from the Edit menu’s 
Find submenu. 

Find and Replace can also be used to add words to the global corrections 
list. See page 18.

• Spell Check. You can find this function under the Tools menu, or use the 
Spell Check button on the Writing toolbar. 

You can use both Find and Replace and Spell Check in both normal 
document view and Edit Underlying Text mode to correct underlying text 
problems.

These functions work the same as when you use them to edit text 
documents. For details, see Chapter 7, Writing and Editing of the Kurzweil 
3000 for Windows User’s Guide.
24



Document Preparation Guide
Working with Pronunciations Dictionaries
Pronunciation is the way a word sounds when it is spoken. When Kurzweil 
3000 reads, you are actually hearing the document’s underlying text as it’s 
read by a speech engine. Each speech engine has its own pronunciations 
dictionary. 

Kurzweil 3000 comes with a number of speech engines, each of which has 
an associated pronunciations dictionary. When you use Kurzweil 3000 to 
read a document, the speech engine references the pronunciation dictionary 
to speak words correctly. 

While the dictionaries are very comprehensive, there are times when 
Kurzweil 3000 encounters a word that the speech engine is unable to 
pronounce correctly. You will typically find that this happens with words such 
as proper names. For example, in a document about Greek mythology, the 
names of gods and goddesses might be pronounced incorrectly. 

Kurzweil 3000 lets you add words to a speech engine dictionary, as well as 
change the pronunciation of any word already in the dictionary. After 
changing the pronunciation for a word, you can test it to hear what it sounds 
like. You can also view and edit the entire pronunciation dictionary. 

The pronunciation editing features also allow you to import and export 
dictionaries to other Kurzweil 3000 users, ensuring that everyone has a 
consistent list.

Which Speech Engine Am I Using?
When you select a Language and a Speaker in the Reading Options pane, 
you’re actually selecting a speech engine. Each speech engine includes its 
own set of speaking voices for a given language. For example, when you 
select English, the Speaker list contains a different set of voices than when 
you select French. Also, the speaking voices are associated with different 
speech engines. The VWKate English speaking voice is associated with the 
Voiceware speech engine, whereas the English speaking voice Reed is 
associated with the ETI-Eloquence Text-to-Speech speech engine.

You can see which speech engine you’re using by looking in the Sample 
Text window in the Reading Options pane. The selected speech engine is 
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also displayed at the bottom of the New Pronunciation dialog box and the 
Pronunciation dialog box.

Using the Pronunciation Editor
Kurzweil 3000 lets you change the pronunciation of any word in a speech 
engine pronunciation dictionary, allowing you to hear the pronunciation you 
want whenever you read. 

Ensure that you have the desired speech engine selected because the 
pronunciation changes you make affect the dictionary of the current speech 
engine.

To change the pronunciation of a word in a document:
1. From the Tools menu, choose Pronunciations to open the New 

Pronunciation dialog box (or select the desired word before selecting 
Pronunciations).

2. In the Word to be Spoken box, type the word for which you want to 
change the pronunciation. 

3. Click in the New Pronunciation box. Type the new pronunciation you 
want.

4. Click Test to hear the new pronunciation. Click OK to set the new 
pronunciation.

Creating the best pronunciation can take multiple tries.
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Select the Test every word check box to direct Kurzweil 3000 to 
automatically pronounce a selected word when you open the 
Pronunciation dialog box. This option must be reselected each time you 
start Kurzweil 3000.

Select Case Sensitive to apply the Pronunciation only when the word 
matches the pronunciation’s specified case. This is useful for 
distinguishing, for example, the word “sat” from the acronym “S.A.T.”

To edit pronunciation in a speech engine dictionary:
1. If necessary, select the desired speech engine in the Reading Options 

pane.

2. From the Tools menu, choose Pronunciations.

3. In the New Pronunciation dialog box, click the Edit button.

The Pronunciations Editor appears.

4. Scroll through the Word to be Spoken list and select the desired word.

5. Click in the Pronunciation box. Type the new pronunciation, or click 
Delete to delete the word.

6. Click OK when you’re done.
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Note: You can lock the ability to edit pronunciations in the Lock Features 
Options pane. See Enabling or Disabling Kurzweil 3000 Features on 
page 339 of the Kurzweil 3000 for Windows User’s Guide.

To hear all of the words in a pronunciations dictionary:
The Test All option is a handy way to review all of the pronunciations in a
dictionary. Selecting this option directs Kurzweil 3000 to read all the 
pronunciations in a dictionary, starting from the currently selected word.
1. From the Tools menu, choose Pronunciations.

2. In the New Pronunciations dialog box, click Edit.
The Pronunciations Editor box appears.

3. In the Pronunciations dialog box, click Advanced.

The Advanced options appear.

4. In the Word to be Spoken window, click on the word where you want to 
start reading.

5. Click Test All.
Kurzweil 3000 begins reading the pronunciation dictionary.

Deleting and Restoring Pronunciations Dictionaries
If over time you have added many pronunciations to a particular dictionary, 
you might, for some reason, want to restore the default dictionary for this 
speech engine.

To delete the current pronunciations dictionary:
1. From the Tools menu, choose Pronunciations.

2. In the New Pronunciations dialog box, click Edit.
The Pronunciations Editor appears.

3. In the Pronunciations Editor dialog box, click Advanced.

The Advanced options appear.
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Optionally, save the current dictionary for future use by exporting it, as 
any pronunciations that you added to the original dictionary are discarded 
when you restore the default dictionary. See Importing and Exporting 
Pronunciations Dictionaries on page 29.

4. Click Delete All.
Kurzweil 3000 deletes all the of the pronunciations.

5. Click Defaults.

Kurzweil 3000 reloads the current speech engine's default pronunciation 
dictionary.

Importing and Exporting Pronunciations Dictionaries
The Import and Export pronunciations options allow you to distribute 
pronunciations dictionaries among Kurzweil 3000 users. This comes in 
handy in situations where there are typically one or two people who perform 
document preparation tasks, and where, as one of their tasks they are 
responsible for adding new pronunciations to a master dictionary. They can 
periodically export the master list and then have other Kurzweil 3000 users 
import it. This ensures that when newly prepared documents are distributed, 
each Kurzweil 3000 user has the most up-to-date pronunciations dictionary.

To export a pronunciations dictionary:
1. From the Tools menu, choose Pronunciations.

2. In the New Pronunciations dialog box, click Edit.
The Pronunciations Editor appears.

3. In the Pronunciations Editor, click Advanced.

The Advanced options appear.

4. Click Export.
5. In the Save As dialog box, navigate to the location where you want to 

save the dictionary.

6. Type a file name for the list, and click Save.
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Kurzweil 3000 saves the list as a text file.

To import a pronunciations dictionary:
1. From the Tools menu, choose Pronunciations.

2. In the New Pronunciations dialog box, click Edit.
The Pronunciations Editor appears.

3. In the Pronunciations Editor, click Advanced.

The Advanced options appear.

4. Click Import.
5. In the Open dialog box, navigate to the location where the dictionary you 

want is located.

6. Click Open.

7. Click OK.

Kurzweil 3000 imports the new pronunciations dictionary, adding its 
words to the currently loaded dictionary and replacing any words that 
match.

Creating Custom Pronunciations Dictionaries
Document-specific pronunciation dictionaries let book producers provide a 
set of pronunciation corrections specific to a set of documents. For example, 
if you have a book on dinosaurs with 20 chapters, each a KES file, you can 
drop one pronunciation file into the folder containing the chapters and correct 
the pronunciations of all of the dinosaur names.

When Kurzweil 3000 opens a document, it will now look into the folder that 
contains the document for a file named pronunciations.srp. That file can 
contain a set of pronunciations that are used in addition to (and logically 
“before”) any pronunciation corrections that the user has in effect.

Note that this file will be used for any language that the user happens to be 
using, and for any speech engine. (This is unlike the global pronunciation 
files, which are language and speech- engine-specific.)
30



Document Preparation Guide
To create a pronunciations.srp file:
1. From the Tools menu, choose Pronunciations.

2. In the New Pronunciations dialog box, click Edit.
The Pronunciations dialog box appears.

3. Set up the exact set of pronunciations desired, then click OK.

4. Exit Kurzweil 3000.

5. In your file system, navigate to 
Documents and Settings\user name\ApplicationData\KESI\Kurzweil 
3000.

6. Make a copy of the relevant .srp file.

That file is named according to the language and speech engine that 
were selected in the Reading Options pane when you created the 
pronunciations dictionary in step 3.

7. Rename the copy to pronunciations.srp. 

8. Place the file in the folder with the .kes files to which you want it to apply.

You should test this file with several speech engines to make sure that it is 
correct for all of them.
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Working with the Header/Footer Editor
Many documents, from books and textbooks to reports, and even worksheets 
and tests, have headers and footers that you may not want Kurzweil 3000 to 
read aloud. Using the Header/Footer Editor, it’s easy to mark such text in 
an image document so that Kurzweil 3000 does not read it. This is 
particularly helpful when you are preparing documents with many pages that 
have consistent areas that do not need to be read.
Notes: 
• The Header/Footer Editor is only available with Kurzweil 3000 

Professional.

• Any change you make in this editor will be saved only if you save the file 
after exiting the editor.

• It’s possible to read headers/footers in a document in which they have 
been marked to not read. In the Reading Options pane, click Skip 
Headers/Footers to deselect it. This enables you to retain the marked 
headers/footers while temporarily allowing you to read them.

• You can add header/footer markers at any time during the document 
preparation process. Kurzweil 3000 does not re-recognize the page as it 
does during zone editing, so things like Sticky Notes and Highlighting will 
not be lost.
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To enter and exit Header/Footer Edit mode:
1. With an image document open, select Header/Footer Editor from the 

Scan menu, or press CTRL+F8.

Kurzweil 3000 appends “Header/Footer Editor is Active” to the 
document name at the top of the Kurzweil 3000 window to indicate that 
the document is now in Header/Footer Editor mode.

.

2. When you are done, select Header/Footer Editor from either the Scan 
menu or the Header/Footer Editor right mouse button menu, or press 
CTRL+F8 again to exit Header/Footer Editor mode.
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Marking Headers/Footers So They Aren’t Read
Use this procedure to mark a header or footer so that Kurzweil 3000 doesn't 
read it.

To mark a header/footer for Kurzweil 3000 not to read:
1. In Header/Footer Edit mode, ensure that there are no headers/footers 

selected.

2. Open the Header/Footer Editor right mouse button menu, and choose 
Mark Header/Footer.
The cursor changes to a crosshair.

3. Use the left mouse button to draw a frame around the header/footer area 
you want to block.

.

When you release the mouse button, the cursor changes to a compass, 
allowing you to move the frame. If you point to the frame’s perimeter, the 
cursor changes to a double arrow, allowing you to adjust its size.

 

Tip: If you plan on applying a header/footer marker to all of a document's 
pages, consider adding extra room around the header/footer when 
drawing the frame. This allows you to accommodate headers/footers on 
other pages that may be higher/lower or off to the side a bit more than the 
header/footer you are marking.

4. Click outside the frame. You can mark additional header(s)/footer(s).

The header/footer marker appears as a green block.
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5. If you want, you can, now apply this block to all the pages throughout the 
document; see the following procedure.

6. When you are done, open the Header/Footer Editor right mouse button 
menu, and choose Header/Footer Editor to exit the editor.

Applying a Header/Footer Marker to All Pages
Use this procedure to apply a header/footer marker to all pages in a 
document so that Kurzweil 3000 doesn't read them.

Tip: If you plan on applying a header/footer marker to all of a document's 
pages, consider adding extra room around the header/footer when drawing 
the frame. This allows you to accommodate headers/footers on other pages 
that may be higher/lower or off to the side a bit more than the header/footer 
you are marking.
Note: The Header/Footer Editor is available only with Kurzweil 3000 
Professional.

To apply a header/footer marker to all of a document’s pages:
Important Note: Before applying a header/footer to all pages, ensure that all 
pages have been scanned.

1. Enter Header/Footer Edit mode.

2. Click the desired header/footer to select it.

3. Open the Header/Footer Editor right mouse button menu, and choose 
Apply to All Pages.

4. Click outside the header/footer.

5. When you are done, open the Header/Footer Editor right mouse button 
menu, and choose Header/Footer Editor to exit the editor.
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Moving or Adjusting the Size of a Header/Footer Marker
You can move or adjust the size of a header/footer marker after you’ve 
created it. You might need to do this, for example, when you are applying a 
header/footer marker to all of the pages in a document. This allows you to 
accommodate headers/footers on other pages that may be higher/lower or 
off to the side a bit more than the header/footer you are marking.

To move or adjust the size of the header/footer marker:
1. In Header/Footer Edit mode, click the desired header/footer to select it.

2. Open the Header/Footer Editor right mouse button menu, and choose 
Adjust Header/Footer.
The green header/footer marker changes to a frame.

3. Use the compass cursor to move the frame.

You can also point to the perimeter of the frame and use the double-arrow 
cursor to resize it.

4. Click outside the frame when you are done.

If a header/footer was previously applied to all pages, a prompt appears, 
giving you the option to also apply the new change to all pages.

5. Press OK to apply the marker to other pages.

The header/footer frame changes to the green header/footer block.

6. When you are done, open the Header/Footer Editor right mouse button 
menu, and choose Header/Footer Editor to exit the editor.
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Unmarking Header and Footers
Use this procedure to unmark headers or footers so that Kurzweil 3000 will 
read them.

To unmark header(s)/footer(s):
There are a few options for unmarking headers and footers.

• Select a single header/footer and choose Unmark Header/Footer from 
the Header/Footer Editor right mouse button menu.

If a header/footer was previously applied to all pages, a prompt appears 
giving you the option to also apply the new change to all pages.

• You can also choose Unmark All Headers/Footers throughout the 
document. This option is available on the Header/Footer Editor right 
mouse button menu regardless of whether a header/footer is selected. In 
the prompt that appears, click OK.

Enabling or Disabling Header/Footer Reading
By default, Kurzweil 3000 reads headers and footers.You can direct Kurzweil 
3000 to not read header/footers without actually unmarking a document’s 
header and footer areas as detailed in the previous procedure.

To enable or disable header/footer reading:
1. From the Tools menu, choose Options.

The Options dialog box appears.

2. Click the Reading icon. 

3. Select or deselect the Skip Reading Headers/Footers option.
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Specifying a New First Page Number
You can designate a number other than one (1) for the first page of an image 
document. All subsequent pages in the set will then follow the newly set first 
page number. 

This is a useful feature when you want your scanned document’s page 
numbers to correspond to the actual document’s pagination.

To set the first page number:
1. From the View menu, choose Page, then Set Number.

The Set Number dialog box appears.

2. Type the number with which you want to begin this set, then click OK.

The page numbers in the status bar and in the toolbar reflect the new 
page numbering.
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Specifying Front Matter Page Numbers
This feature comes in handy when you want to have two distinct page 
numbering schemes in a scanned document, such as when you are 
distinguishing preface material from actual chapter pages or when 
accommodating a Table of Contents.

When you select the Document has Front Matter option in the Set Page 
Number dialog box and specify the number of pages in the front matter, 
Kurzweil 3000 places front matter page numbers within parentheses. For 
example, if in a nine-page document, you specify that there are three front 
matter pages, the pages are renumbered as follows: “(1–3) and 1–6.” 
Note: You can also use the Set Page Number feature to set the first page 
number to any number greater than zero. See Specifying a New First Page 
Number on page 38.

To set front matter pagination:
1. Place the cursor in the desired document.

2. From the View menu, choose Page, then Set Number. 
3. In the Set Page Number dialog box, click the check box for Document 

has Front Matter.

4. Type the number of front matter pages.

5. Click OK.
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Cleaning Up Image Documents
Scanned documents can often contain crease marks, specks or other “dirty” 
areas. You can use the Image Fill feature to remove these types of 
blemishes. For image documents in general, you can also use this feature to 
remove potentially distracting images for students with attention issues.

Using Image Fill, you specify an area, and then fill the area with a color you 
select. For crease marks and other blemishes, you will probably want to 
choose a color that matches the surrounding “page” color. To remove images 
from a page, you can choose from a list of suggested colors, or use the color 
picker.

To clean up images using a suggested color:
1. Open the document you want to clean up.

2. From the Edit menu, choose Image Selector.
The cursor changes to a crosshair.

3. Click and drag to create a box around the area you want to clean up.

4. From the Scan menu, click Image Fill to see a list of possible fill colors.

Your choices are Black and White if it is a black and white document 
(scan or existing image document). If your document is in color, you can 
choose between a range of colors, or use the color picker (see the 
following procedure).

5. Click a color. You cannot undo this operation.

Kurzweil 3000 fills the specified area, removing the marks or image from 
the page.

When you fill an area that contains recognized text, only the image of the 
text is removed, leaving the underlying text undisturbed. In this situation, 
Kurzweil 3000 prompts you as to whether you want to re-recognize the 
page in order to remove the underlying text under the filled area. If you 
click No, Kurzweil 3000 reads and highlights the words, but you will not 
see them on the page, which could be confusing. 
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To clean up images with the color picker (color documents only):
1. Open the document you want to clean up.

2. From the Edit menu, choose Image Selector.
The cursor changes to a crosshair.

3. Click and drag to create a box around the area you want to clean up.

4. From the Scan menu, click Image Fill, and select Color Picker.
The Color Picker lets you choose a fill color by clicking on any color in the 
document.

5. In the document, click the color you want to use as the fill color.

The Color Picker dialog box appears, displaying the color you picked.

6. Click OK accept the fill color, or No to cancel the operation.

If you accepted the color, Kurzweil 3000 fills the specified area with it. If 
you cancelled, you can go back to the Scan menu, and choose Image 
Fill again to pick another color.

When you fill an area that contains underlying text, the image of the text 
is removed, but the underlying text remains undisturbed. In this situation, 
Kurzweil 3000 prompts you as to whether you want to re-recognize the 
page in order to remove the underlying text under filled area. Click Yes to 
remove the text. If you click No, Kurzweil 3000 reads and highlights the 
words, but you will not see them on the page, which could be confusing.

Note: You can add the Image Fill command to the right mouse button menu, 
as well as the number of colors it displays. Keep in mind that if you do not 
include black and/or white as two of the colors, the menu will not display 
anything when you are in a black and white document.
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Inserting Images into Your Documents
You can use the Insert Image command to insert a BMP, TIFF or JPEG 
image file into either an image or text document. 

If you are inserting the image into an existing document, Kurzweil 3000 
inserts the image as a new page in front of the current page.

To insert an image into an image document:
1. Open an existing image document.

or

From the File menu, click New, and choose Image File.

2. If you’re inserting the image into an existing image document, go to the 
page that you want to insert the image in front of.

3. From the Scan menu, choose Insert Image.

4. Navigate to the image file that you want to insert, select it, and choose 
Open.

Kurzweil 3000 creates a new page, and inserts the file into it.
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Using Ranked Spelling to Correct Spelling 
Errors

The Ranked Spelling feature provides useful statistics such as the 
percentage of correctly spelled words in a document and the number of 
words misspelled. It lists misspelled words by the frequency of their 
occurrence and provides the commands for correcting them in the same 
dialog box.

Ranked Spelling is an ideal tool for quickly assessing how much of a 
document, particularly a large book, is correctly spelled, and prioritizing the 
corrections you want to make. As you correct errors, Kurzweil 3000 
continues to update the statistics, enabling you to make further assessments. 

Here’s an example of how you might use Ranked Spelling. Let’s say you start 
out with a document that has 95 percent of its words spelled correctly, and 
you’d like to improve that rate to a respectable 98 percent. By using Ranked 
Spelling, you find that only three misspelled words have the highest number 
of occurrences, and therefore are causing the greatest number of errors. By 
applying the Change All command for each of these three misspellings, you 
can significantly, and quickly, improve the file’s accuracy rate, without having 
to go through the document, correcting one misspelled word at a time.

To make corrections with Ranked Spelling:
1. Open an image or text document.

2. From the Tools menu, choose Ranked Spelling.

The Ranked Spelling dialog box appears. At the top, the dialog box 
displays the percentage of the words in the file that are spelled correctly 
and the number of misspelled words. Each misspelled word is displayed 
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in the Word column, with number of times it appears in the document 
displayed in the Occurrence column.

3. Click on a word in the Word column.

4. Decide how you want Kurzweil 3000 to handle the possible error. 

In cases where a word appears multiple times in the document, click 
Context to move through the document and highlight each occurrence.

To:

• Correct the error and change all instances of the misspelling in the 
document, select a word from the Suggestions list or type your 
correction into the Change To box, then click Change All.

• Ignore the word throughout the document and not save it to the spelling 
dictionary, click Skip All.

• Add the word to your personal spelling dictionary, click Add.
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When you select an action (Skip All, Change All, Add) it appears in the 
Action column, but it has not been applied yet. If you want to change or 
cancel an action, select the word and click Clear Action.

5. Click Apply or OK to direct Kurzweil 3000 to perform the selected action 
for each word.
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Changing the Language Format of Image Text
If the document you are preparing contains text in two or more languages, 
you can change the language format of selected text by marking it as being 
in a particular language. When marked, Kurzweil 3000 automatically reads 
the text using the appropriate reading language.

To mark text as a particular language you must have a speech engine for that 
language. Out of the box, Kurzweil 3000 lets you mark text as English, 
French, Spanish, German or Italian. If you add a third-party speech engine 
for a different language, Kurzweil 3000 will recognize it and allow you to mark 
text with the new language.

The Language List
In order to actually mark text, the Language list must be available on a 
toolbar. By default, the Language list is included with the Writing toolbar set. 
It is also included with the Language Learning toolbar set. See Applying 
Sample Toolbar Sets on page 223 of the Kurzweil 3000 for Windows User’s 
Guide.

Alternatively, you might want to customize the Reading toolbar set by adding 
the Language list to it. See Customizing Toolbars on page 218 of the 
Kurzweil 3000 for Windows User’s Guide.

You can also change the language format of text in text documents. See 
Changing the Language Format of Text on page 146.

To change the language format of image text:
1. In an image document, select text that you want to mark.

2. In the toolbar, choose the desired language from the Language list.

Kurzweil 3000 marks the text with the selected language. 

3. If you click in the portions of the document that have different language 
formats, the Language list updates, showing the format of the current 
text.
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